--- title: "Turn on Microsoft Network Protection" slug: "microsoft-network-protection" updated: 2024-04-09T23:20:39Z published: 2024-04-09T23:20:39Z canonical: "docs.redcanary.com/microsoft-network-protection" --- > ## Documentation Index > Fetch the complete documentation index at: https://docs.redcanary.com/llms.txt > Use this file to discover all available pages before exploring further. # Enable Microsoft Network Protection in Microsoft Defender Microsoft Network Protection prevents your employees from experiencing internet-based events by blocking access to specific domains. Follow the procedure below to enable Microsoft Network Protection. ## Setup your Microsoft Network Protection To turn on Microsoft Network Protection, [watch the Microsoft Defender for Endpoint Network protection video](https://docs.microsoft.com/en-us/microsoft-365/security/defender-endpoint/network-protection?view=o365-worldwide#overview-of-network-protection), and then follow the steps provided in the video. ## Review Network Protection Events You can view what was audited or blocked by Microsoft Network Protection by using this advanced hunting query in the Microsoft365 Defender Console: ```plaintext DeviceNetworkEvents |where ActionType in ('ExploitGuardNetworkProtectionAudited','ExploitGuardNetworkProtectionBlocked') ```